VerticaPy

Python API for Vertica Data Science at Scale

Functionality by Vertica Version

VerticaPy is compatible with Vertica v8.0.x and above, but the the availability and exact functionality of certain functions and models in VerticaPy depend on the version of your Vertica database.

Vertica 8.0.x

Vertica 8.1.x

Vertica 9.0.x

Vertica 9.1.x to 9.3.x

Vertica 10.0.x

Vertica 10.1.x

Function Prerequisites

Some features in VerticaPy have dependencies. For more information, see optional packages.